git » debian:kxd » commit 03f757e

New upstream patch: upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch

author Maximiliano Curia
2014-07-14 10:56:25 UTC
committer Maximiliano Curia
2014-07-14 10:56:25 UTC
parent 520dc2a33ae1f1487d990a81377020c5d0d3f715

New upstream patch: upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch

debian/changelog +2 -0
debian/patches/series +1 -0
debian/patches/upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch +45 -0

diff --git a/debian/changelog b/debian/changelog
index 02e55be..6a82c40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,5 +4,7 @@ kxd (0.12-1~) UNRELEASED; urgency=medium
   * Add Vcs-* control fieds.
   * Update init script.
   * Add kxd.lintian-overrides for the init file.
+  * New upstream patch: upstream_scripts-Fix-kxd-add-client-key-missing-
+    fi-and-wrong-.patch
 
  -- Maximiliano Curia <maxy@debian.org>  Sun, 13 Jul 2014 15:11:07 +0200
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..e84e98b
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch
diff --git a/debian/patches/upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch b/debian/patches/upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch
new file mode 100644
index 0000000..be2f0cb
--- /dev/null
+++ b/debian/patches/upstream_scripts-Fix-kxd-add-client-key-missing-fi-and-wrong-.patch
@@ -0,0 +1,45 @@
+From 65d281acfc99d0c67bfc2e7d5c1582f79f9dcb3a Mon Sep 17 00:00:00 2001
+From: Alberto Bertogli <albertito@blitiri.com.ar>
+Date: Sun, 13 Jul 2014 14:31:23 +0100
+Subject: [PATCH] scripts: Fix kxd-add-client-key missing "fi" and wrong
+ variable
+
+Somehow, scripts/kxd-add-client-key is missing a "fi" to close the "if"
+statement, and uses $SERVER instead of $CLIENT in a couple of places.
+
+This patch fixes that.
+
+Thanks to Maximiliano Curia for reporting the issue.
+
+Signed-off-by: Alberto Bertogli <albertito@blitiri.com.ar>
+---
+ scripts/kxd-add-client-key | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/scripts/kxd-add-client-key b/scripts/kxd-add-client-key
+index eff0d56..dbeb958 100755
+--- a/scripts/kxd-add-client-key
++++ b/scripts/kxd-add-client-key
+@@ -5,7 +5,7 @@ set -e
+ CLIENT="$1"
+ KEYNAME="$2"
+ 
+-if [ "$SERVER" = "" ] || [ "$KEYNAME" = "" ]; then
++if [ "$CLIENT" = "" ] || [ "$KEYNAME" = "" ]; then
+ 	echo "
+ Usage: kxd-add-client-key <client hostname> <key name>
+ 
+@@ -15,8 +15,9 @@ corresponding configuration (including a randomly generated key) in
+ /etc/kxd/data/<client hostname>/<key name>/.
+ "
+ 	exit 1
++fi
+ 
+-CONFIGPATH="/etc/kxd/data/$SERVER/$KEYNAME"
++CONFIGPATH="/etc/kxd/data/$CLIENT/$KEYNAME"
+ 
+ echo "Creating directory ($CONFIGPATH)"
+ mkdir -p "$CONFIGPATH"
+-- 
+2.0.1
+