git » debian:dnss » commit d67d39b

Update compat and debhelper (to 11)

author Alberto Bertogli
2018-04-15 20:03:51 UTC
committer Alberto Bertogli
2018-04-15 20:11:55 UTC
parent d9b7bb16484ac80d300d5602c31c942a7f9242d3

Update compat and debhelper (to 11)

As per current recomendation, update compat and debhelper versions.
This required minor changes to debian/rules.

debian/changelog +2 -0
debian/compat +1 -1
debian/control +1 -1
debian/rules +3 -1

diff --git a/debian/changelog b/debian/changelog
index 244c3df..bd111e5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,8 @@ dnss (0.0~git20180415.0.18b15770-1) UNRELEASED; urgency=medium
   * dnss.1: Fix typo in SYNOPSIS
   * Update Standards-Version to 4.1.4
   * Remove deprecated flag from systemd's service file
+  * Update compat and debhelper (to 11)
+  * Adjust systemd build rules to the new debhelper compat
 
  -- Alberto Bertogli <albertito@blitiri.com.ar>  Sun, 15 Apr 2018 20:07:24 +0100
 
diff --git a/debian/compat b/debian/compat
index ec63514..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+11
diff --git a/debian/control b/debian/control
index 1e6512a..fa907c4 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: net
 Priority: optional
 Maintainer: Debian Go Packaging Team <pkg-go-maintainers@lists.alioth.debian.org>
 Uploaders: Alberto Bertogli <albertito@blitiri.com.ar>
-Build-Depends: debhelper (>= 10),
+Build-Depends: debhelper (>= 11),
                dh-golang,
                golang-any,
                golang-blitiri-go-log-dev,
diff --git a/debian/rules b/debian/rules
index 9458751..05b7c57 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,9 @@
 #!/usr/bin/make -f
 
+include /usr/share/dpkg/pkg-info.mk
+
 %:
-	dh $@ --buildsystem=golang --with=golang --with=systemd
+	dh $@ --buildsystem=golang --with=golang
 
 # No need to install the source files, this is a binary package.
 override_dh_auto_install: