From e5b1abe3b5dc235b083953e8fba01a0acf53e484 Mon Sep 17 00:00:00 2001
From: Alberto Bertogli <albertito@blitiri.com.ar>
Date: Mon, 25 Oct 2021 12:26:02 +0100
Subject: [PATCH 1/2] Add Go modules information
Newer Go compilers need a main module to exist in order to build
binaries, so this patch adds it.
Since there are no external dependencies, there is no `go.sum` file.
---
README.md | 2 +-
go.mod | 3 +++
2 files changed, 4 insertions(+), 1 deletion(-)
create mode 100644 go.mod
diff --git a/README.md b/README.md
index 3f61e13..bcc2e5a 100644
--- a/README.md
+++ b/README.md
@@ -72,7 +72,7 @@ assumption that the server's host is secure and trusted.
There are no runtime dependencies for the kxd and kxc binaries.
-Building requires Go 1.11.
+Building requires Go 1.15.
The configuration helper scripts (`create-kxd-config`, `kxc-add-key`, etc.)
depend on: `bash` and core utilities (`mkdir`, `dd`, etc.).
diff --git a/go.mod b/go.mod
new file mode 100644
index 0000000..fcdfd19
--- /dev/null
+++ b/go.mod
@@ -0,0 +1,3 @@
+module blitiri.com.ar/go/kxd
+
+go 1.15
--
2.33.0